Partial Performance Degradation

Incident Report for Ortto

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 23:48 UTC

Investigating

We are currently investigating an issue affecting performance on some accounts. We will provide further updates as we gather more information.
Posted Mar 27, 2025 - 20:13 UTC
This incident affected: Ortto application and Ortto API.